1. Hello!

    First of all, welcome to MapleLegends! You are currently viewing the forums as a guest, so you can only view the first post of every topic. We highly recommend registering so you can be part of our community.

    By registering to our forums you can introduce yourself and make your first friends, talk in the shoutbox, contribute, and much more!

    This process only takes a few minutes and you can always decide to lurk even after!

    - MapleLegends Administration-
  2. Experiencing crashes with 'Unknown Error'? Make sure you are on the latest MapleLegends version. The current latest version is found by clicking here.
    Dismiss Notice

Low 23 May 2020 Client does not work with AMD SVM enabled

Discussion in 'Report Bugs' started by geospiza, May 23, 2020.

Thread Status:
You must be a logged-in, registered member of this site to view further posts in this thread.
  1. geospiza
    Online

    geospiza Slime

    18
    5
    20
    Apr 16, 2020
    10:30 PM
    geospiza
    Dragon Knight
    Description of the bug: (optional screenshot/video):

    When running the new client (23 May 2020) on Windows 10 Home (Version 2004. OS Build 19041.264) with AMD SVM (Secure Virtual Machine) enabled in the bios, the client fails to open with the an ijl15.dll error "Sorry, this application cannot run under a Virtual Machine.". This is followed by another dialog "The application was unable to start correctly (0xc0000142)."

    Screenshot 2020-05-23 12.17.37.png
    Screenshot 2020-05-23 12.17.52.png

    Disabling SVM in the bios allows the client to enter to login screen.
    Enabling SVM in the bios reproduces the above issue.

    What is supposed to happen?:

    The client should enter the login screen, regardless of the virtualization settings in the bios.

    Where did you find and/or notice this bug?:

    I found this while updating to the new version of the client (23 May 2020).

    A step-by-step guide to re-producing this bug (optional)
    Extra information (optional):

    I am running on a pre-release version of Windows 10 so I can run WSL 2 and use Docker for Windows. Disabling virtualization is inconvenient (but okay, because I can't get enough MapleLegends recently).

    Another player shared the same issue (AMD, Windows 10 Pro, OS Build 18362), where disabling virtualization fixed the problem. A separate player (Intel, Windows 10 Pro) had/has the same issue, but disabling Hyper-V did not solve the problem.

    UPDATE:
    With the server coming online, there have been new reports of this issue. There are also several players who do not see the virtual machine error with virtualization enabled on AMD (e.g. Windows 10, Version 1909, OS Build 18363).

    UPDATE 2:
    In case you aren't able to view further into this thread, here some handy information for resolving the immediate issue so you can enjoy the ongoing event.

    Here's a visual guide for enabling virtualization on your computer, either Intel VT-x or AMD SVM. Make sure to disable instead of enabling.

    1. Confirm your error and settings. Check whether virtualization is enabled under "Task Manager > Performance".
    Screenshot 2020-05-24 00.34.01.png
    2. Restart your computer and mash the button to take you to the BIOS or UEFI options. On my PC it's DEL, but it varies between manufacturers.
    3. Find the option for virtualization and disable it. If you have an AMD CPU, this might be known as SVM or AMD-V. If you have an Intel CPU, this may be known as VT-x. A search engine is your friend if you can't seem to find it.
    4. Save your settings and verify that virtualization is disabled in the Task Manager on login.

    If you are having issues running outside of a VM, and are not running Windows 10 Pro or an AMD chipset, please leave a comment. I'd be curious to hear about other weird edge-cases.
     
Thread Status:
You must be a logged-in, registered member of this site to view further posts in this thread.

Share This Page