1. Hello!

    First of all, welcome to MapleLegends! You are currently viewing the forums as a guest, so you can only view the first post of every topic. We highly recommend registering so you can be part of our community.

    By registering to our forums you can introduce yourself and make your first friends, talk in the shoutbox, contribute, and much more!

    This process only takes a few minutes and you can always decide to lurk even after!

    - MapleLegends Administration-
  2. Experiencing disconnecting after inserting your login info? Make sure you are on the latest MapleLegends version. The current latest version is found by clicking here.
    Dismiss Notice

Guide for Windows Alt+Enter doesn't work / GR2D Error!

Discussion in 'Technical Issues' started by Lily, Jun 24, 2017.

  1. hiKam
    Offline

    hiKam Snail

    1
    0
    0
    Feb 8, 2020
    Male
    12:05 PM
    same issue. i also followed the steps for the later and no luck. D: any other solutions found?
     
  2. Arxus
    Offline

    Arxus Mano

    10
    0
    19
    Jan 11, 2020
    Male
    1:35 AM
    Arxus
    Hey did you manage to do this? My monitor is 3440x1440 and i have tried everything posted in just about every forum and i cannot get Maplelegends or Legends+ to run :(
     
  3. arechao4
    Offline

    arechao4 Blue Snail

    4
    0
    7
    Apr 1, 2020
    Male
    12:05 PM
    RyRy4
    Thief
    28
    Hello, I have also tried to do what is said on this guide and it did not work.
    I am using 1920x1080 on Radeon rx 5500 XT graphic card. Please help! I am not sure exactly what to do.
     
  4. michaelxii
    Offline

    michaelxii Horny Mushroom

    41
    15
    56
    Oct 6, 2018
    Male
    9:05 AM
    michaelxii
    F/P Arch Mage
    200
    California
    I ran into a new flavor of the cursed GR2D error this week.
    OnionF6

    To give some context, I purchased a new Dell monitor, which led to ML not working... aka "Failed in finding proper screen mode for Gr2D."


    Most of this thread is dedicated to figuring out why the fullscreen mode (Alt+Enter) does not work. However, I was not trying to use fullscreen...because I need multiple clients.
    OnionMuha

    Furthermore, the Gr2D bug typically pops up when the monitor refresh rate is 59 Hz instead of 60 Hz. I opened NVIDIA control panel and found that the monitor refresh rate was already 60 Hz.
    NVIDIA Panel.JPG

    On the Windows side, there are display refresh settings that are different than NVIDIA/AMD/Intel graphics control. You can access it from Windows 10's Settings application. Go to System, then Display, and then click on "Advanced display settings". I saw a window that looked like this.
    59 Hz.JPG
    To my dismay, I saw that NVIDIA control panel reported 60 Hz, but Windows 10 reported 60 Hz. I clicked on the "Display adapter properties for Display 1", and it showed the 59 Hz refresh rate in the "Monitor" tab. I tried switching the screen refresh rate to 60 Hz, but the Settings application kept showing 59 Hz.
    General PNP.JPG

    I stumbled across this Microsoft forum post. https://support.microsoft.com/en-us...ndows-does-not-apply-the-user-selected-settin
    It basically says that the 59 Hz is not a bug, because Windows equates both 59 and 60 Hz settings to 59.94 Hz...
    OnionDead

    So after this, I was still stuck with Gr2D errors, and Windows telling me it was not a bug. I could not play ML either.OnionGhost

    However, the CRU utility from earlier in this thread allowed me to fix the issue. Originally, the CRU utility verified the 59.94 Hz behavior. You can see the 59.95 Hz for the monitor's native resolution.
    Dell Before.JPG
    If you delete that default "detailed resolution", you can replace it with the correct 60 Hz setting through the Add feature. Here are my details for the added default resolution. Only change the frequency to 60.000 Hz.
    Freq Adjust.JPG
    Your CRU utility should look something like this afterward. Notice the exact 60.000 Hz resolution?
    Dell After.JPG OnionF2

    After doing all this work, I was finally able to boot maple and multiclient again. OnionCrazy
    multiclient.JPG
     
    • Like Like x 4
  5. db42
    Offline

    db42 Red Snail

    5
    6
    6
    Jul 16, 2020
    Male
    Israel
    7:05 PM
    orix22
    Cleric
    40
    Pokemons
    In Case None Of The Above Worked :
    (Note: Comment was moved from another post here)

    Does the game only work when you use HDClient = 1?
    If HDClient = 2 is what causing your Gr2D error, try the following:

    1. Open Legends.ini and make sure HDClient = 2 > Save (Resets Every Patch)
    2. Open CRU as admin and Under "Detailed resolutions .." click Add
    3. Change Horizontal to 1366 and Vertical to 768 (everything should auto change)
    4. Make sure the refresh rate is the same as the monitor for example 60.000
    5. Compare to the image below and click OK on both the Add Screen&CRU
    6. Find the restart64.exe file in the same folder where CRU is and run it as admin.
    Annotation 2020-08-05 231749.png
    • Enjoy your new screen space!
    • Didn't work? Make sure you did the changes to the right screen, on the top left corner of CRU there is an option to select a screen
     
    • Like Like x 6
    • Great Work Great Work x 2
  6. Kofuku
    Offline

    Kofuku Slime

    16
    10
    25
    May 28, 2017
    Female
    Netherlands
    6:05 PM
    Cleric
    This processes changed my 2560x1440 monitor to a 1080 monitor which I cant change back neither in display settings nor in nvidia control panel, it says 1080 is the highest and now recommended resolution of my monitor, which it isn't.

    What has this program done to my monitor resolution? How do I get my 2560 resolution back?

    Please help, thanks.
     
  7. Tate
    Offline

    Tate Capt. Latanica

    352
    229
    278
    Apr 16, 2020
    New Zealand
    4:05 AM
    Potayto
    Shadower
    175
    Beaters
    right click the reset file and run as admin, then turn off and turn on your computer.
     
  8. makujah
    Offline

    makujah Red Snail

    7
    0
    10
    Nov 14, 2020
    Male
    RF, Moscow
    7:05 PM
    Cleric
    40
    Oh my dood it worked! You bloody bastard, thank you! :D

    I will only add that you need to restart after you add that new detailed resolution for changes to apply.
     
  9. CloudHeart
    Offline

    CloudHeart Red Snail

    9
    1
    5
    Sep 6, 2020
    5:05 PM
    Not a single suggestion worked for me, but this is how i ended up fixing it (also as a note to myself for next time)

    I run 1440p monitors, using NVIDIA graphics. Issue is that my monitors default to something like 59.994hz, which isn't accepted.

    1: open Nvidia control panel and navigate to Change resolution.
    2: Click the Customize button.
    3: Click Create Custom Resolution
    4: In the Timing section change the Standard: to Manual
    5: Now that your allowed to change the timing settings, change the Refresh rate from 60.000HZ to 60.001HZ
    6: Click Test and accept the changes
    7: Do this for all monitors
    8: In the resolution list (in the Change Resolution tab) select the custom resolution and apply it to each monitor

    Next Phase
    1: Open Windows display settings
    2: Open Advanced display settings
    3: Select one of your monitors (this will need to be done for all)
    4: Click Display adapter properties for display(number)
    5: Open the tab Monitor
    6: Change Screen Refresh Rate to 60Hertz
    7: Apply the changes
    8: Repeat this for each monitor

    In the advance display settings the Refresh rate should now show as 60.001Hz, and Maple Legends should now also run. Without first adding the custom resolution you can still change window's it's Hz to 60, but after saving it will instantly jump back to 59Hz.
     
    • Like Like x 1
    • Friendly Friendly x 1
  10. likey
    Offline

    likey Timer

    108
    59
    130
    Jan 12, 2018
    12:05 AM
    Latch
    Bowmaster
    Perion
    i want to give up i tried everything ;w;
     
  11. Shikuma
    Offline

    Shikuma Snail

    1
    0
    0
    Jan 17, 2022
    Male
    6:05 PM
    Thief, Beginner
    Dear,

    I followed the steps to prevent this error when I boot up Maplelegends. Still after setting my screen resolution to 60HZ and also downloading and configure the settings in CRU.exe I still get the same error.

    I have a 1900x1200 monitor resolution by default. I use GeForce and also checked every settings that needs to be checked/unchecked within the controlpanel of my graphic card.

    Now if I want to start maple I need to adjust my screen resolution towards 1600x... in order to boot it up. Then switch back to my native resolution 1900x1200.

    Did I miss a step in the proces of fixing this issue? Or do I need to keep adjusting my resolution if I wanna play? It's not a big deal to do it the way I did untill now, but it would be great if I found a solution for my problem.

    FYI: Just started on this server 3 days ago and really enjoyed it so far! Great community!

    Kind regards,

    xShikuma (IGN)
     
  12. Siegfried
    Offline

    Siegfried Master Chronos

    99
    33
    111
    Apr 21, 2017
    Male
    9:05 AM
    For AMD & AMD iGPUs (such as Ryzen's)

    1. Download AMD Adrenaline's Control Panel software
    2. Visit GPU settings > Enable GPU Scaling

    Tested on Steam Deck APU multibooting into Windows, but should also work for other AMD gpus/igpus
     

Share This Page